Can't install Australian Postcodes


I am having trouble with a fresh install. I have worked through as many of the guides as I can as possible;

I am using Ubuntu 16.04 server on a VMware Playstation so I can easily back it up ect (will upgrade this later).

I have Java 8, mysql 5.7 I think I have made the required changes, tomcat8 and the connector java.

I follow through all the instructions and I can compile the webapp, then I can log into it and use it.

My problem is the very last step - loading the Australian postcodes.

From the bin directory, I sudo ./ ../import/data/postcodesAU.xml

It all seems to flash past without a worry. The last line is Processed 32235 objects in 34.00 seconds (948.09 objects/sec).

I then restart Apache and Tomcat8. The problem is I can no longer access the webapp using the same address (ip address:8080/openvpms). I have tried restarting the server and many other things to no luck. I have dropped the database and gone through the intructions several times and the same problem keeps happening.

It seems without the postcodeAU.xml loaded - the webapp works seamlessly. Once it is loaded. It somehow crashes it and I can no longer to access it to even log in?

Any help appreciated.



Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Re: Can't install Australian Postcodes

* omitted that I'm trying with OpenVPMS version 2.1.1

Re: Can't install Australian Postcodes

Are you going to http://localhost:8080/openvpms/login ?

Can you see anything in <TOMCAT_HOME>/logs/openvpms-full.log ?

Re: Can't install Australian Postcodes

Thanks Tim, that prompted me to look at the logs, with a bit of reading, it seems that either tomcat or java wasn't given enough memory.

I opened a configuration file by

sudo nano /etc/default/tomcat8

Found the line that reads JAVA_OPTS="-Djava.awt.headless=true -Xmx128m -XX:+UseConcMarkSweepGC"

and I changed 128m to 1024m. I think there are more specific settings you could put in here if you knew a bit more about it but after the above basic change I was able to restart the server and it all works well with the postcodes loaded.

Hope this helps someone else.




Syndicate content